ACSite.NET 線上服務論壇

疑問與討論 => 雲端 VPS 主機使用疑問 => 主題作者是: vincentliao 於 三月 23, 2009, 10:24:03 am



主題: (文件)Magento_安裝在_cpanel_whm_的虛擬主機環境中...
作者: vincentliao三月 23, 2009, 10:24:03 am
(文件)Magento_安裝在_cpanel_whm_的虛擬主機環境中...


Magento 一個新潁的購物車程式, 支援 multi-store多商店功能...




通常使用 whm/cpanel 的虛擬主機都會缺一些 mode
引用
magento-core/Lib_Varien requires PHP extension "PDO"
magento-core/Lib_Varien requires PHP extension "curl"
magento-core/Lib_Varien requires PHP extension "pdo_mysql"


只要再從新的 rebuild apache 一下就可以


(WHM) ==) (Admin) ==) (Software) ==) (EasyApache_(Apache_Update)) ==)  (Start_customizing_Based_On_Profile)

第一大類...Apache...相關模組...
Apache Built-in ModulesOptions in this color are enabled by default in Apache. That means that you won't see anything added to Apache's configure line unless it is unchecked.  Asis
 Auth Digest
 AuthnAlias
 AuthnAnon
 AuthnDBD
 AuthnDBM
 AuthnDefault
 AuthnzLDAP
 AuthzDBM
 AuthzOwner
 Bucketeer
 Cache
 CaseFilter
 CaseFilterIn
 Cern Meta
 Charset Lite
 DAVFs
 DAVLock
 DBD
 Dav ==)  Among other things mod_dav can be used by DAV enabled Frontpage clients instead of FP extensions
 Deflate
 Disk Cache
 Distcache
 Dumpio
 Echo
 Env
 Expires
 ExtFilter
 Mod FCGID fastcgi support
 File Cache
 Fileprotect  Prevent Users from reading other webroots
 Frontpage
 Headers
 Ident
 Imagemap
 LDAP
 Log Forensic
 MPM Event Before choosing *any* MPM read and understand the documentation that can found by clicking "More Info"
 MPM Prefork (recommended) Before choosing *any* MPM read and understand the documentation that can found by clicking "More Info"
 MPM Worker Before choosing *any* MPM read and understand the documentation that can found by clicking "More Info"
 MemCache
 Mime Magic
 Optional Fn Export
 Optional Fn Import
 OptionalHookExport
 Optional Hook Import
 Mod SuPHP This option will make the following changes to your profile prior to the build:
  Enables:  CGI (PHP v4)  CGI (PHP v5) 
 Proxy  required for cPanel/WHM/Webmail/Webdisk proxy VirtualHost support
 Speling
 UniqueId
 Usertrack
 Version
 Vhost Alias


第二大類...Apache...不常用之相關模組...
Other Modules EAccelerator for PHP
  v0.9.5.3 - caches compiled PHP pages ONLY when running in a persistent (DSO/FCGID) manner
IonCube Loader for PHP
  3.1.34 - please read documentation that can found by clicking "More Info" to fully understand this option
Mod Bandwidth
  v2.1 for Apache 1.3, v0.8 for Apache 2.x - see documentation that can found by clicking "More Info" for details
Tomcat
  v5.5.25 - Experts ONLY: Do not install this unless you have a tomcat admin.
Mod Mono (.Net 1.x)
  v2.2 - Experts ONLY: Do not install this unless you have a mono admin This option will make the following changes to your profile prior to the build:
  Disables: Mod Mono (.Net 2.x)
Mod Mono (.Net 2.x)
  Not currently compatible with mod_mono .Net 1.x support, one will be dropped This option will make the following changes to your profile prior to the build:
  Disables:  Mod Mono (.Net 1.x)
Mod Perl
  v2.0.4 - not needed to run CGI scripts
Mod Security
  v1.9.5 for Apache 1.3, v2.5.7 for Apache 2.x This option will make the following changes to your profile prior to the build:
  Enables:  UniqueId
Suhosin for PHP
  v0.9.27 - please read documentation that can found by clicking "More Info" to fully understand this option
SourceGuardian Loader for PHP
  7.1 - please read documentation that can found by clicking "More Info" to fully understand this option
Zend Optimizer for PHP
  3.3.3 - please read documentation that can found by clicking "More Info" to fully understand this option


第三大類...php...相關模組...
PHP 5.2.9 (Be sure to "harden" your PHP since PHP has many security issues)For more information about PHP configuration, capabilities, and limitations please see http://www.php.net. Options in this color are enabled by default in php 5.2.9. That means that you won't see anything added to php's configure line unless it is unchecked.  Bcmath
 Bz2
 CGI
 Calendar
 Concurrent DSO patch
  Allows PHP 4 and 5 to load simultaneously as Apache modules (not compatible with Zend optimizer and some extensions)
 Curl
 CurlSSL
 Curlwrappers
 Dbase
 Discard Path ==) may interfere with running PHP as CGI
 Exif
 Expat  You may need this to address http://bugs.php.net/bug.php?id=45996 for PHP 5.2.8 and older
 FTP
 Fastcgi   This option will make the following changes to your profile prior to the build:
    Enables:  Mod FCGID
 Force CGI Redirect
 GD  This option will make the following changes to your profile prior to the build:
    Enables:   Zlib
 Gettext
 Iconv  Support iconv character set conversion facility
 Imap
 MM
 Magic Quotes
 MailHeaders
 Mbregex
 Mbstring
 Mcrypt
 Mhash
 Mime Magic
 Ming (Not Recommended due to various problems) using ming library 0.4.2
 Mysql  compile MySQL support using the PHP bundled libraries (if the System MySQL option is checked it takes precedence over this option)
 Mysql of the system
   compile mysql (and mysqli if its checked) support against the system libraries
 MySQL "Improved" extension.
   MySQLi does not replace the standard MySQL extension. Requires MySQL 4.1 or later. !! mysqli may not work on all systems, contact your support provider for mysqli support !!
 Openssl
 PDO  Includes SQLite support. MySQL support is available. If you plan on installing or updating PDO drivers (freetds, oracle, etc) via PECL you might want to skip this option as PECL will install the version of PDO it has.
 PDO MySQL  This option will make the following changes to your profile prior to the build:
   Enables:  PDO
 POSIX
 Path Info Check
 Pear
 PGsql click here for details
  Requires PostgreSQL 7.3 or higher to already be installed. You can do that with /scripts/installpostgres
 Pspell
 SNMP  Requires the SNMP Dev libraries to be installed first!!!
 SOAP
 SafeMode
 Safe PHP CGI  prevents users from overriding system php.ini
 Sockets
 TTF (FreeType)
 Tidy
 Wddx
 XSL
 XmlRPC
 Zend Multibyte
 Zip
 Zlib  Requires that zlib is installed and up to date
 Save my profile with appropriate PHP 5 options set so that it is compatible with cpphp
    This option will make the following changes to your profile prior to the build:
    Enables:  CurlSSL  FTP  GD  Gettext  Iconv  Imap  Mbregex  Mbstring  Mysql  Mysql of the system  PGsql  Sockets  Zlib

 






挑挑選選...重新的建一下 Apache, 記得要選一下  pdo / curl 這幾個 php 的 mod ...


約十到二十分鐘搞定...lol...