回 ACSite.NET 首頁
回 ACSite.NET 首頁 客服系統 帳務系統 英文首頁
nav_seperator
nav_seperator
nav_seperator
nav_seperator
 

頁: [1]
  列印  
作者 主題: 如何完整架設 Gallery?  (閱讀 7753 次)
aa45123
客戶
*
離線 離線

文章: 6


« 於: 四月 04, 2005, 08:45:26 pm »

我使用 Fantastico 安裝 gallery, 再嘗試加上 zh-TW.utf8 的 locale 之後, gallery 的診斷程式顯示出挸:
Testing to see which system locales (if any) are absent.
These locales are required to use multilanguage capabilities of Gallery when your PHP has gettext support. They are also needed to show date and time in the according format to the language.         

Serious Warning!

We were unable to detect any system locales. Multi-language functions will be disabled. Please install the corresponding locales or ask your administrator to do this. This problem is known on Debian systems. In this case please have a look at this Debian locale HowTo (http://people.debian.org/~schultmc/locales.html,<連結已死>).
懇請協助!!

其他的項目也顯示找不到
NetPBM, ImageMagick, jhead, jpegtran...等程式
請問是否需另外安裝,或是其路徑是什麼?

謝謝!!
已記錄
acsite
管理員
Hero Member
*****
離線 離線

文章: 4,027


個人網站
« 回覆文章 #1 於: 四月 04, 2005, 09:11:06 pm »

ImageMagick的路徑請參考 http://forum.acsite.net/big5/index.php?showtopic=144

至於gallery的問題正在進行研究
已記錄
aa45123
客戶
*
離線 離線

文章: 6


« 回覆文章 #2 於: 四月 04, 2005, 11:01:18 pm »

改成/usr/bin/, 診斷如下:
We are going to test each ImageMagick binary individually.
Checking: '/usr/bin/identify'    Expected status: 0, but actually received status 127.
Checking: '/usr/bin/convert'    Expected status: 0, but actually received status 1.

改成/usr/X11R6/bin/, 診斷如下:
We are going to test each ImageMagick binary individually.
Checking: '/usr/X11R6/bin/identify'    Expected status: 0, but actually received status 127.
Checking: '/usr/X11R6/bin/convert'    Expected status: 0, but actually received status 1.

測試上傳圖片, 得到無法製作縮圖"unable to make thumbnail" 之回應
ImageMagick 似乎仍然有問題...
 
已記錄
acsite
管理員
Hero Member
*****
離線 離線

文章: 4,027


個人網站
« 回覆文章 #3 於: 四月 05, 2005, 04:20:35 am »

請使用 PM 提供gallery管理者的登入訊息
以便實際登入查看原因
已記錄
aa45123
客戶
*
離線 離線

文章: 6


« 回覆文章 #4 於: 四月 05, 2005, 03:38:43 pm »

Gallery 的 login information 已寄出
有關 ImageMagick,
---------------------------------------------------------------------------------------------------------------------------------------------
 You told the config wizard that your ImageMagick binaries live here:

      /usr/bin

If that is not right (or if it is blank), re-run the configuration wizard and enter a location for ImageMagick.
Note: Your ImageMagick directory (/usr/bin) is not in your open_basedir list

      /home/aa45123:/usr/lib/php:/usr/local/lib/php:/tmp

The open_basedir list is specified in php.ini.
The result is, that we can't perform all of our basic checks on the files to make sure that they exist and they're executable.
---------------------------------------------------------------------------------------------------------------------------------------------
是否意指除了指定 ImageMagick 的路徑 (/usr/bin/)之外,必需在php.ini 設定 path ??
 
已記錄
acsite
管理員
Hero Member
*****
離線 離線

文章: 4,027


個人網站
« 回覆文章 #5 於: 四月 05, 2005, 07:00:18 pm »

我們測試之後會使用PM回覆您 微笑  
已記錄
aa45123
客戶
*
離線 離線

文章: 6


« 回覆文章 #6 於: 四月 10, 2005, 01:05:16 am »

剛才又試著自行安裝Gallery, 改用 1.5 RC3版
除了 locale 部分之外, 似乎一切正常.

Gallery Configuration Wizard顯示如下:
---------------------------------------------------------------------------------------------------------------------------
Testing to see which system locales (if any) are absent.
These locales are required to use multilanguage capabilities of Gallery when your PHP has gettext support. They are also needed to show date and time in the according format to the language.         

Serious Warning!

We were unable to detect any system locales. Multi-language functions will be disabled. Please install the corresponding locales or ask your administrator to do this. This problem is known on Debian systems. In this case please have a look at this Debian locale HowTo.
(http://people.debian.org/~schultmc/locales.html)
----------------------------------------------------------------------------------------------------------------------------
其中, Debian locale How to的連結又通了!!

Configuring Locales
The Easy Way

   1. Install debconf (i.e. run apt-get update then apt-get install debconf, as root)
   2. Run dpkg-reconfigure locales as root

The Hard Way

   1. Edit /etc/locale.gen as root. If /etc/locale.gen does not exist, create it. An example /etc/locale.gen is below.
   2. Run /usr/sbin/locale-gen as root

A sample /etc/locale.gen

# This file lists locales that you wish to have built. You can find a list
# of valid supported locales at /usr/share/i18n/SUPPORTED. Other
# combinations are possible, but may not be well tested. If you change
# this file, you need to rerun locale-gen.
#
# XXX GENERATED XXX
#
# NOTE!!! If you change this file by hand, and want to continue
# maintaining manually, remove the above line. Otherwise, use the command
# "dpkg-reconfigure locales" to manipulate this file. You can manually
# change this file without affecting the use of debconf, however, since it
# does read in your changes.

en_US.UTF-8 UTF-8
---------------------------------------------------------------------------------------------------------------
煩請您幫我安裝debconf, 或許可以解決我的問題!!!!!!!!!
謝謝!!!!!!!!!
 
已記錄
aa45123
客戶
*
離線 離線

文章: 6


« 回覆文章 #7 於: 四月 10, 2005, 01:44:34 am »

測試了一下, 還是不行做縮圖......
看來gallery的問題頗多, 我放棄了!!!!!!!!
debconf不是重點, 不用麻煩了!
Thank you anyway!
 
已記錄
頁: [1]
  列印  
 
前往:  



 
 
bottom
Copyright © 2002 - 2017 ACSite.NET All Rights Reserved.