回 ACSite.NET 首頁
回 ACSite.NET 首頁 客服系統 帳務系統 英文首頁
nav_seperator
nav_seperator
nav_seperator
nav_seperator
 

頁: [1]
  列印  
作者 主題: 一個現象  (閱讀 3946 次)
yesonline
客戶
***
離線 離線

文章: 159


« 於: 七月 29, 2006, 07:10:08 am »

我最近發現一個「現象」,目前無法用實例來說,因為目前這現象尚未現實發生,但卻也發生多次,引起我的注意。

就是我的某些有架站但「冷門」的網址,說冷門是因為我確定沒什麼訪客(搜尋引擎之外的真人)之外,連我也是一個星期可能才想到去看一下。而常常(不能說每次,但次數也足夠讓我注意到)是第一次打上網址後,瀏覽器就開始在網路上一直尋找,最後則是出現找不到網頁。我的經驗就是要嘛換個網址的打法,例如本來有打www的,換成沒打www的,或者相反。不然就是先去別的網站逛一下再回來重打一次,大概經過這樣的過程後就可以順利連上網站了。

我的「感覺」像是,因為這個網站平常根本沒人去,所以所有的DNS上都沒有它的cache或紀錄,我等於是近期第一個去找的人,它於是透過層層傳達往上找,但在結果回來前我已因時間逾時而回報找不到網頁。這純是我的猜測,不知你們是否有什麼答案?還是主機這邊DNS解析的問題?

這個現象出現的頻率已算值得我憂慮了。我不知道有多少人初次的訪客因此以為網站不存而離開? B)

謝謝先 ㄏㄏㄏ  
已記錄
acsite
管理員
Hero Member
*****
離線 離線

文章: 4,027


個人網站
« 回覆文章 #1 於: 七月 29, 2006, 07:58:57 am »

能否請您使用PM或是信件提供兩三個這類的網址
以便為您進行測試
謝謝 微笑  
已記錄
yesonline
客戶
***
離線 離線

文章: 159


« 回覆文章 #2 於: 八月 01, 2006, 06:12:59 am »

今天上午六點六分時,又有這個現象,第一次去(我自己是好幾天沒上這個站,估計也沒有其他人去 ㄏㄏㄏ ),結果就是找不到網頁。等我抓好圖之後,再reload一次,ok,網站又出現了。顯然又是因為太久沒去,第一次汽車發不動的感覺。
我想既然網站從未當,為何會出現這種狀況呢?一個網站如果很久沒有人去,或者沒有來自某地區的訪客,例如台灣好了,是否等有第一個去的人,台灣的ISP才會「開始」去「找」這個網站(層層上訪),等找到它的IP後再層層回報。熱門的站自然很快就可回傳,而從未去過的站,isp這邊的dns也沒有任何資料,所以如果層層傳報的時間久一點就有可能在user這裡出現找不到網頁的情形?
這是我的猜測 伸舌頭

http://img341.imageshack.us/img341/9818/000000ge2.gif
已記錄
acsite
管理員
Hero Member
*****
離線 離線

文章: 4,027


個人網站
« 回覆文章 #3 於: 八月 01, 2006, 06:32:53 pm »

我們今日使用 hinet 與 seednet 隨機連線您提供的網址
不過一直沒有發現您說的問題
所以仍無法確定原因

就理論上來說
就算是一個很久沒人訪問的網址
當第一個人連線時,其流程應該是這樣的:

第一個人連線 -> 向 ISP DNS 查詢 -> ISP DNS 向 root DNS 查詢該網域名稱的 Nameserver-> ISP DNS 向該網域名稱的 Nameserver 查詢 IP -> ISP DNS 回報 IP

就算是熱門的網址,當ISP DNS快取的時限到達時
也一樣要經過上述程序重新取得IP
所以除非該網域名稱的 Nameserver (也就是我們主機) 回覆IP的速度不夠快
否則理論上應該不會發生您說的問題才是

我們會再針對我們DNS伺服器檢查看看
已記錄
yesonline
客戶
***
離線 離線

文章: 159


« 回覆文章 #4 於: 八月 02, 2006, 11:39:33 am »

瞭解,我也只是純猜測的 :lol:  
已記錄
頁: [1]
  列印  
 
前往:  



 
 
bottom
Copyright © 2002 - 2017 ACSite.NET All Rights Reserved.